Unable to see appliance configuration details in the Cloud Director Availability vSphere Client Plug-In
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Unable to see appliance configuration details in the Cloud Director Availability vSphere Client Plug-In

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Article ID: 315151

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • When reviewing the Cloud Director Availability On-Premises appliance configuration through the Cloud Director Availability vSphere Client Plug-In, you see a similar error:
The request can not be processed, because the HTTP method for the resource is not supported.
  • In /var/log/vmware/vsphere-ui/logs/vsphere_client_virgo.log on vCenter server, you see entries similar to:
[2020-07-03T01:30:52.719Z] [WARN ] http-nio-5090-exec-17         com.vmware.rest.client.AbstractRestClient                         The HTTP response has no body. Code = 405, reason =
[2020-07-03T01:30:52.741Z] [ERROR] http-nio-5090-exec-17         com.vmware.h4.vsphere.ui.controller.C4ProxyController             Backend responded with error java.lang.reflect.InvocationTargetException: Failed to mirror replicator call: GET /config/network/dns
        at com.vmware.h4.vsphere.ui.controller.C4ProxyController.mirrorReplicatorRequest(C4ProxyController.java:451)
        at com.vmware.h4.vsphere.ui.controller.C4ProxyController.access$400(C4ProxyController.java:54)
        at com.vmware.h4.vsphere.ui.controller.C4ProxyController$2.call(C4ProxyController.java:168)
        ...
Caused by: com.vmware.rest.client.exception.UnexpectedJsonResponseStatusError: Unexpected response status: 405
        at com.vmware.rest.client.converters.DefaultJsonConverter.deserializeError(DefaultJsonConverter.java:55)
        at com.vmware.rest.client.AbstractRestClient.convert(AbstractRestClient.java:219)
        at com.vmware.rest.client.json.RestClient.exchange(RestClient.java:104)
        at com.vmware.h4.vsphere.ui.controller.C4ProxyController.mirrorReplicatorRequest(C4ProxyController.java:438)
        ... 122 common frames omitted

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Environment

VMware Cloud Director Availability 4.x
VMware vCloud Availability 3.0.x
VMware vCloud Availability 3.5.x

Cause

This issue can occur when the the Cloud Director Availability vSphere Client Plug-In version doesn't match the current Cloud Director Availability On-Premises appliance version.

Resolution

To resolve this issue reconfigure the Lookup Service endpoint to reinstall Cloud Director Availability vSphere Client Plug-In.
  1. Log into the vSphere Client with an administrator user.
  2. Navigate to Administration > Solutions > Client Plug-Ins.
  3. Note the Cloud Director Availability plug-in version.
Note: The name of the plug-in is vCloud Availability for the 3.x releases.
  1. Log into the Cloud Director Availability On-Premises appliance management portal.
  2. Navigate to the About section and verify the current version of the appliance.
  3. If there is a mismatch between the plug-in and appliance versions navigate to the Configuration section of the On-Premises appliance.
  4. In the Service endpoints section click Remove next to the Lookup Service Address.
  5. In the pop-up window enter the SSO administrator credentials and click Remove.
  6. When redirected to the Getting Started page, click Run initial setup wizard.
  7. Re-enter the Lookup Service Details and click Next.
  8. In the Site Details section skip repairing with the cloud site and complete the setup wizard.
  9. In the vSphere Client, log out and log back in as an administrator user to verify the plug-in has been updated.