Recovered VM fails to import into Cloud Director during a failover or migrate in Cloud Director Availability 4.x
search cancel

Recovered VM fails to import into Cloud Director during a failover or migrate in Cloud Director Availability 4.x

book

Article ID: 315142

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:

  • When performing a failover or migration in Cloud Director Availability, the recovered VM fails to import into Cloud Director with a similar error:
Network interface 'Network adapter 1' uses network 'DVSwitch: 50 14 05 22 ## ## ## ##-## ## ## ## 95 c3 f7 4b', which is not accessible.
  • This issue occurs when the Provider VDC of the target Organization VDC is backed by multiple resource pools in vCenter Server.



Environment

VMware Cloud Director Availability 4.x
VMware Cloud Director 10.x

Cause

This issue occurs because Cloud Director attempts to relocate a test failover VM during import. This task fails as Cloud Director performs the relocate before it has sanitised the source site networking information from the recovered VM.

The relocate task is initiated when the placement algorithm in Cloud Director determines the test VM would be better placed on a different resource to the one it was on when initiating the import from vCenter Server to Cloud Director.

Resolution

This issue is resolved in Cloud Director 10.3.3, available at Broadcom Downloads.

Workaround:
To work around this issue, perform either of the following actions:

  • Ensure that the target Storage Policy for a replication is accessible only by a single Provider VDC resource pool.
  • Power off the source vApp which causes Cloud Director to undeploy the source networking and connect the source VMs to a placeholder network called none that is universal across all Cloud Director instances. Then migrate the VM to ensure a final synchronization is performed to update the network settings of the source VM during the recovery task.