"Replication with id 'null' was not found." error when configuring configuring replications in vCloud Availability
search cancel

"Replication with id 'null' was not found." error when configuring configuring replications in vCloud Availability

book

Article ID: 315135

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:

  • When configuring a new outgoing replication, you see the following error in the Replications Tasks view of the vCloud Availability Portal:
Replication with id 'null' was not found.
  • In /opt/vmware/h4/cloud/log/cloud.log on the vCloud Availability vApp Replication Manager on the recovery site, you see similar messages:
2019-04-11 06:40:31.993 ERROR - [UI_/portal/outgoing-replications/Provider_Site/vapp_########-####-####-####-########a0c7_a8_Xc] [https-jsse-nio-8046-exec-3] c.v.h.c.c.error.ExceptionAdvisor         : A request from Tenant_Site[192.168.2.117] to /vm-replications/C4-########-####-####-####-########0913 failed.
com.vmware.h4.manager.api.exceptions.ReplicationNotFoundException: Replication with id 'null' was not found.
        at sun.reflect.GeneratedConstructorAccessor230.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
        at com.vmware.h4.exceptions.GenericServerExceptionProvider.get(GenericServerExceptionProvider.java:70)
        at com.vmware.h4.exceptions.GenericServerExceptionProvider.get(GenericServerExceptionProvider.java:47)
        at com.vmware.h4.common.H4ClientFactory.lambda$new$0(H4ClientFactory.java:53)
2019-04-11 06:40:31.994  WARN - [UI_/portal/outgoing-replications/Provider_Site/vapp_########-####-####-####-########a0c7_a8_Xc] [https-jsse-nio-8046-exec-3] .m.m.a.ExceptionHandlerExceptionResolver : Resolved [com.vmware.h4.manager.api.exceptions.ReplicationNotFoundException: Replication with id 'null' was not found.]
  • In the vCloud Availability Replication Manager service management portal, under System Monitoring one or more Replicators are in an error state or showing as not connected.

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Environment

VMware vCloud Availability 3.0.x
VMware vCloud Availability for Cloud-to-Cloud DR 1.x

Cause

This issue can occur when there is an error with the registration of vCloud Availability Replicator to the vCloud Availability Replication Manager in the same site.

Resolution

To resolve this issue, resolve the Replicator to Replication Manager pairing by either repairing it or removing and creating a new pairing.

Repairing the connection

To repair the Replicator to Replication Manager pairing, perform the following steps:
  1. In a browser, navigate to the vCloud Availability Replication Manager service management portal:
https://Replication-Management-Appliance-IP-Address:8441/ui/admin
  1. Log in as root.
  2. Navigate to the Replicators view.
  3. Select the Replicator in an error state.
  4. Click the Repair button.
  5. In the pop-up window enter the Replicator and SSO details, then click Apply.

Removing and creating a new pairing

To remove a Replicator to Replication Manager pairing, perform the following steps:
  1. In a browser, navigate to the vCloud Availability Replication Manager service management portal:
https://Replication-Management-Appliance-IP-Address:8441/ui/admin
  1. Log in as root.
  2. Navigate to the Replicators view.
  3. Select the Replicator in an error state.
  4. Click the Remove button.
  5. In the pop-up window, confirm the action by clicking Remove.
To create a new Replicator to Replication Manager pairing, follow the steps in the Register a vCloud Availability Replicator with a vCloud Availability Replication Manager in the Same Site section of the vCloud Availability documentation.