"Unable to send email..." error when sending a test email notification in the Cloud Director Availability Provider Portal
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"Unable to send email..." error when sending a test email notification in the Cloud Director Availability Provider Portal

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Article ID: 315134

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • Sending a test email notification from the Events and Notification view of the Cloud Director Availability Provider Portal fails, and you see an error similar to: 
Unable to send email for Organization 'System' and following destination addresses '[...]'.
  • This issue occurs even though the email notification system is configured and working in Cloud Director, but not for Cloud Director Availability.


Environment

VMware Cloud Director Availability 4.x
VMware vCloud Availability 4.0.x

Cause

This issue can occur when communication between the Cloud Replication Management Appliance and the SMTP server is blocked.

Resolution

To resolve this issue, perform the following steps to determine where the block may be:
  • Ensure that SMTP server is reachable from Cloud Replication Management Appliance over port 25.
  • Add the SMTP domain name under Settings > Network > Domain Search Path of the Cloud Replication Management Appliance if it’s on different domain other than the Cloud Replication Management Appliance.
  • If there is a RELAY Network in the environment, ensure that there are no blocked ports between the RELAY and the Cloud Replication Management Appliance.
  • Add the SMTP server's entry in the /etc/hosts file on the Cloud Replication Management Appliance.