Error: "Unable to process the request due to bad parameter 'diskSize'..." when creating new a migration in Cloud Director Availability 4.x
search cancel

Error: "Unable to process the request due to bad parameter 'diskSize'..." when creating new a migration in Cloud Director Availability 4.x

book

Article ID: 315133

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • When you create a new replication, the task fails and you see a similar error:
Unable to process the request due to bad parameter 'diskSize' -> '322143091200'.
  • In /opt/vmware/h4/cloud/log/cloud.log on the Cloud Director Replication Management Appliance, you see entries similar to:

2020-06-10 09:42:33.378 ERROR - [UI__########-####-####-########] [task-poller-2] com.vmware.h4.jobengine.JobExecution   : Task ########-####-####-######## (WorkflowInfo{type='start', resourceType='vmReplication', resourceId='C4-########-####-####-########', isPrivate=false, resourceName='null'}) has failed

com.vmware.vdr.error.exceptions.BadUserInput: Unable to process the request due to bad parameter 'diskSize' -> '322143091200'.
    at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
    at java.base/jdk.internal.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)

  • If using independent disks, you see a similar error:

“Failed to update independent disk: urn:vcloud:disk:########-####-####-########".

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Environment

VMware Cloud Director Availability 4.x
VMware vCloud Availability 3.5.x

Cause

This issue can occur when the size of the source virtual machine's hard disk is not a whole number when converted to megabytes (MB).

Resolution

To resolve this issue, increase the size of any affected disks on the source VM before attempting a new migration. The steps to do this vary depending on whether the source site is an On-Premises or Cloud deployment.

On-Premises source site

  1. Log into the vSphere Client in the source site.
  2. Navigate to the VM you want to protect.
  3. Right-click on the VM and click Edit Settings.
  4. In the Edit Settings window, increase the disk size.
Note: The disk size must be a whole number when converted to MBs.
  1. Click OK.

Cloud source site

  1. Log into the Cloud Director Portal in the source site.
  2. Navigate to the VM you want to protect.
  3. Click Details.
  4. Under Hardware, click Hard Disks.
  5. In the Hard Disks view click Edit.
  6. In the Edit Hard Disks window, increase the disk size.
Note: The disk size must be a whole number when converted to MBs.
  1. Click Save.