Policy based management error in the destination site when configuring replications in vCloud Availability 3.x
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Policy based management error in the destination site when configuring replications in vCloud Availability 3.x

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Article ID: 315125

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • Configuring a new replication in vCloud Availability fails with the error:
Operation aborted due to an unexpected error.
  • In /opt/vmware/h4/cloud/log/cloud.log on the vCloud Availability Replication Management appliance, you see entries similar to:
2020-07-03 10:26:28.389 ERROR - [UI-a0bdd683-84a0-4555-a2be-7d29d06fa9f9-1p-Vk-Hw] [job-6] com.vmware.h4.jobengine.JobExecution     : Task 434370ae-b5d1-4dad-8a29-b42d0b5bec1c (WorkflowInfo{type='setupDestination', resourceType='replication', resourceId='H4-ba8a63a4-5c41-4923-9cae-fb1c9b0ae5e1', isPrivate=false, resourceName='null'}) has failed
java.lang.NullPointerException: null
        at com.vmware.vlsi.client.sso.Ls2Gateway.findPbm(Ls2Gateway.java:69)
        at com.vmware.h4.replicator.vc.PbmConnector.pbmEndpoint(PbmConnector.java:64)
        at com.vmware.h4.replicator.vc.PbmConnector.getPbmSettings(PbmConnector.java:59)
        at com.vmware.h4.replicator.vc.PbmConnector.withPbmConnection(PbmConnector.java:50)
        at com.vmware.h4.replicator.services.PbmService.getRawStoragePolicy(PbmService.java:41)
        at com.vmware.h4.replicator.replication.util.DiskHelper.getProfileSpec(DiskHelper.java:170)
        at com.vmware.h4.replicator.replication.util.DiskHelper.makeDisk(DiskHelper.java:121)
        at com.vmware.h4.replicator.replication.util.StorageHelper.createVmdks(StorageHelper.java:63)
        at com.vmware.h4.replicator.replication.SetupDestinationJob.execute(SetupDestinationJob.java:180)
        at com.vmware.h4.replicator.replication.SetupDestinationJob.execute(SetupDestinationJob.java:71)

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Environment

VMware vCloud Availability 3.0.x
VMware vCloud Availability 3.5.x

Cause

This issue can occur when the vSphere Storage Monitoring Service registration in the Lookup Service contains a different site ID compared to the vCenter Server.

Resolution

To verify you are experiencing this issue, compare the Lookup Service registrations for the vSphere Storage Monitoring Service and vCenter Server.

  1. SSH to the Platform Services Controller and log in as root.
  2. Export the service registration list by running the following command:
/usr/lib/vmidentity/tools/scripts/lstool.py list --url http://localhost:7080/lookupservice/sdk > sso_services
  1. Compare the Site ID of the SMS and vCenter Server registrations with the command:
grep -i 'Service Type: sms\|Service Type: vcenterserver' -B 3 -A 5 sso_services


If the service registrations don't have matching Site IDs, contact VMware Support and note this Article ID (79878) in the problem description. For more information, see How to Submit a Support Request.

Additional Information

For an example output of the SMS and vCenter Server registrations, see below:

root@vcsa [ ~ ]# grep -i 'Service Type: sms\|Service Type: vcenterserver' -B 3 -A 5 sso_services
        Name: cis.sms.ServiceName
        Description: cis.sms.ServiceDescription
        Service Product: com.vmware.vim.sms
        Service Type: sms
        Service ID: 53241412-b3e8-4d63-a8bc-8ccd6070151a
        Site ID: test-site
        Node ID: 72f4bf92-e9c0-4d1b-be0d-2c9f0146a6a3
        Owner ID: [email protected]
        Version: 6.5
--
        Name: AboutInfo.vpx.name
        Description: AboutInfo.vpx.name
        Service Product: com.vmware.cis
        Service Type: vcenterserver
        Service ID: 99391072-8e6f-4c5e-a037-c515ce8bfc26
        Site ID: test-site
        Node ID: 72f4bf92-e9c0-4d1b-be0d-2c9f0146a6a3
        Owner ID: [email protected]
        Version: 6.5