Free disk space field reports high disk usage in the System Health view on VMware Cloud Director Availability 4.x
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Free disk space field reports high disk usage in the System Health view on VMware Cloud Director Availability 4.x

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Article ID: 315092

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

In the System Health view of the VMware Cloud Director Availability Provider Portal, the free disk space is low and displays a warning symbol in the Service status section.

Environment

VMware Cloud Director Availability 4.x

Cause

This issue can occur when the journalctl logs, /var/log/messages, and /var/log/auth.log files increase in size where they consume a large amount of the space on the root filesystem.

Resolution

To resolve this issue, blank out these files to reclaim the used space:

  1. SSH to the impacted Cloud Director Availability appliance and log in as root.
  2. Check the current disk space usage on the appliance:
df -h
  1. Verify the messages and auth.log files are among the top files taking up space on the appliance:
cd /
find -type f -exec du -Sh {} + | sort -rh | head -n 10
  1. Blank out the messages and auth.log files to reclaim the used space:
echo > /var/log/messages
echo > /var/log/auth.log
  1. Verify that the disk usage has been sufficiently reduced.
  2. If there is still not enough free space please run the following command to reduce the size of the journalctl logs:

    journalctl -–vacuum-size=200M 

  3. In a browser, navigate to the System Health view to confirm the disk space warning is gone.

Additional Information

For more information on other ways to free space, see Free up VMware Cloud Director Availability appliance disk space.