H4DM log files grow rapidly in size in Cloud Director Availability 4.x
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H4DM log files grow rapidly in size in Cloud Director Availability 4.x

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Article ID: 315083

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • The service management interface for one or more of the Cloud Director Availability Replicator Appliances displays a warning about the disk space utilization or a warning is seen in the System Health view regarding the available disk space.
  • The most current VMC data ending log file, /opt/vmware/h4/h4adm/log/h4dm.log.<YYYY>-<MM>-<DD>, on the Replicator Appliance is 1GB or higher.
  • This issue occurs when Cloud Director Availability is configured to utilize the VMC data engine and is replicating traffic to a public cloud location such as Azure VMware Solution or VMC on AWS.


Environment

VMware Cloud Director Availability 4.x

Cause

This issue occurs because replications with a public cloud site can generate a large amount of log entries and consume additional storage depending upon the Cloud Director Availability configuration, the number of replications, and the destination site.

Resolution

To resolve this issue, adjust the H4DM logging to reduce the amount of data recorded in the h4dm.log.<YYYY>-<MM>-<DD> files:
  1. SSH to the Replicator Appliance experiencing the issue.
  2. Navigate to the H4DM configuration folder:
cd /opt/vmware/h4/h4dm/conf/conf.toml
  1. Create a backup of the conf.toml file.
  2. Edit the conf.toml file with a text editor and locate the [logging] section.
  3. Add the following line within the [logging] section:
env_filter = "warp::filters::trace=off,h4dm=debug,nfclib_sys=warn,database=info,epic=debug,h4dm::rest::handlers::nfcstream=warn"
  1. Restart the H4DM service:
systemctl restart h4dm

Note: Restarting the H4DM service will temporarily interrupt replication traffic and may result in RPO violations until the replications recover.