No preserved instances are displayed when retrying a partially completed failover in Cloud Director Availability 4.x
book
Article ID: 315076
calendar_today
Updated On:
Products
VMware Cloud Director
Issue/Introduction
This article provides information on how to manage the failover of a replication after a previous failover attempt was not successful.
Symptoms:
When re-trying a failover to a cloud site that previously did not complete successfully, no preserved instances are displayed during the previous failover attempt is unavailable for selection in Cloud Director Availability 4.x.
In the recovery site, you see that the virtual machine from the initial failover attempt was successfully created on the vCenter Server, but the subsequent import into Cloud Director failed.
Environment
VMware Cloud Director Availability 4.x
Cause
This behaviour occurs when a virtual machine has already been created and registered in the underlying vSphere environment of the recovery site. When the virtual machine is recovered in vCenter Server, Cloud Director Availability no longer has an associated instance for that replication and will be unable to display it for selection when retrying the failover.
Resolution
Workaround: To complete the failover of the replication, first review the reason why the initial failover was unable to import the recovered virtual machine into Cloud Director and remediate this issue before re-attempting the failover.
Once the issue behind the initial import failure has been resolved, retry the failover and simply click Next on the Recovery Instance section of the failover workflow.