"Timeout has occurred" error in the Events and Notifications view of the Provider Portal in Cloud Director Availability 4.x
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"Timeout has occurred" error in the Events and Notifications view of the Provider Portal in Cloud Director Availability 4.x

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Article ID: 315075

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • When navigating to the Events and Notifications view in the Cloud Director Availability Provider Portal, you see a similar message when attempting to review the Provider Events section:
Timeout has occurred
  • The display may appear for a short time before it is replaced with the timeout error.
  • On navigating to the Tenant Events section of the Events and Notifications, the timeout error does not occur in this view.


Environment

VMware Cloud Director Availability 4.x

Cause

This issue occurs if there are a high number of system administrators configured in the connected Cloud Director instance.

When loading the interface for the provider events, Cloud Director Availability iterates over all of the system level users in the Cloud Director to collect rights and email information. If there are a high number of users, the time required to complete this can exceed the overall timeout for generating the display.

Resolution

This is a known issue affecting Cloud Director Availability 4.x.

Workaround:
To work around this issue, the number of users to notify can be limited in Cloud Director using the following procedure:
  1. Log into the Cloud Director Provider Portal with a System Administrator user.
  2. Navigate to the Administration view.
  3. In the left pane, click Email under the Settings section.
  4. In the Email configuration screen, click Edit.
  5. In the new window, click Notification Settings.
  6. Click These email addresses in the Send system notifications to section.
  7. In the text box, enter a comma separated list of email addresses you want to notifications to be sent to.
  8. Click Save.
On navigating back to the Cloud Director Availability Provider Portal and refreshing the Events and Notifications view, you see that the page now successfully loads.