No Organization NSX Gateways are listed in the L2 Stretch view of the Cloud Director Availability Provider Portal
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Article ID: 315071
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Updated On:
Products
VMware Cloud Director
Issue/Introduction
Symptoms:
In the L2 Stretch view of the Cloud Director Availability Provider Portal, no Organization NSX Edge Gateways are visible.
In the /opt/vmware/h4/cloud/log/cloud.log file on the Cloud Replication Management Appliance, you see entries similar to:
2023-02-28 14:22:27.095 ERROR - [UI-88392844-4a23-4f0a-88ae-fab9e7148e8a-r2303-MV] [https-jsse-nio-8443-exec-2] c.v.h.c.c.error.ExceptionAdvisorBase : A GET request from System@DRAAS-01[192.168.11.1] to /inventory/vdcs/d56fa3d2-9062-40ee-b61e-9f307290d18e/edge-gateways?offset=0&limit=100 failed. java.lang.NullPointerException: null at com.vmware.h4.cloud.vcloud.inventory.LocalVcloudInventoryService.lambda$getUplinkSubnets$10(LocalVcloudInventoryService.java:651) at java.base/java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:176) at java.base/java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1655) ...
This issue occurs when you are using Cloud Director 10.4.1 or later.
This issue occurs if at least one of the Organization NSX Edge Gateways use IP Spaces.
Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.
Environment
VMware Cloud Director Availability 4.x
Cause
This issue occurs because Cloud Director Availability is not IP Space aware, this results in Cloud Director Availability not being able to list the available Organization NSX Edge Gateways when IP Spaces are in use.
Resolution
This issue is resolved in Cloud Director Availability 4.6.1 available at Broadcom Downloads.
Workaround: To workaround this issue, do not use IP Spaces in Organizations that are enabled for replication in Cloud Director Availability.