Topology and new replication wizard UI elements are slow to load in the Cloud Director Availability vSphere Client Plug-In
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Topology and new replication wizard UI elements are slow to load in the Cloud Director Availability vSphere Client Plug-In

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Article ID: 315064

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • The number of available local sites in the Topology section of the Dashboard view is slow to load in the Cloud Director Availability vSphere Client Plug-In.
  • The New Outgoing Protection/Migration wizard is slow to load when configuring a virtual machine for replication in the vSphere Client.
  • This issue occurs when you are using the Cloud Director Availability vSphere Client Plug-In for a vSphere DR and migration deployment of Cloud Director Availability.
  • This issue occurs when you have multiple vCenter Replication Management Appliances registered in the same site.


Environment

VMware Cloud Director Availability 4.x

Cause

This issue occurs when at least one of the registered vCenter Replication Management Appliances in the local site is offline. The Cloud Director Availability vSphere Client Plug-In checks the health status of all registered vCenter Replication Management Appliances and if any are offline then the UI element will only load once the health check times out.

Resolution

This issue is resolved in Cloud Director Availability 4.5.0.1, available at VMware Downloads.

Workaround:
To work around this issue if you do not want to upgrade, ensure that all registered vCenter Replication Management Appliances are powered on and operational.

If a listed vCenter Replication Management Appliance no longer exists in the site, you can work around this by unregistering the Cloud Director Availability vSphere Client Plug-In and re-registering it with the existing vCenter Replication Management Appliances.
  1. Log into the Manage Object Browser using vSphere administrator credentials:
https://vc_address/mob/?moid=ExtensionManager&method=unregisterExtension
  1. Enter com.vmware.vcda.plugin into the extensionKey parameter value field.
  2. Click Invoke Method to unregister the VCDA extension.
  3. Log into the vCenter Replication Management Appliance Admin Portal as the root user.
  4. In the left pane click Settings.
  5. In the Service endpoints section, click Edit for the Lookup Service address field.
  6. In the new window, enter the vSphere administrator credentials and click Apply.
  7. Repeat steps 4-8 for all other active vCenter Replication Management Appliances.
  8. Navigate to the vSphere Client and confirm that the Cloud Director Availability vSphere Client Plug-In has been redeployed and the stale vCenter Replication Management Appliance is no longer listed.