"Authentication failed" error when logging in with a Cloud Director user in the Cloud Director Availability Provider Portal
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"Authentication failed" error when logging in with a Cloud Director user in the Cloud Director Availability Provider Portal

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Article ID: 315063

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • When you try to log into the Cloud Director Availability Provider Portal using Cloud Director credentials fails, and you see the error:
Authentication failed.
  • When you click on Peer Sites in the left pane in the Cloud Director Availability Provider Portal, you are immediately logged out.
  • In the /opt/vmware/h4/cloud/log/cloud.log file on the Cloud Replication Management Appliance, you see similar messages to:
2023-02-24 07:23:48.094 DEBUG - [UI-c20bd5ea-666b-426e-803b-209f08a412ed-r020-VK] [job-35] c.v.h4.cloud.service.DiagnosticsService  : Unable to connect to the VCD

com.vmware.exception.CommunicationException: No route to host (Host unreachable)
      at com.vmware.exception.converter.ClientExceptionConverter.convertException(ClientExceptionConverter.java:70)
      at com.vmware.rest.client.AbstractRestClient.genericExchange(AbstractRestClient.java:158)
      at com.vmware.vcloud.client.json.JsonVcloudClient.loginJson(JsonVcloudClient.java:178)
Caused by: java.net.NoRouteToHostException: No route to host (Host unreachable)
      ...
2023-02-24 07:44:15.195  WARN - [30f011d7-b69e-4077-a3f1-07cef7f679e0] [health-check-10] c.v.h4.cloud.vcloud.VcloudConnector      : Could not establish local vCD system connection

com.vmware.exception.CommunicationException: No route to host (Host unreachable)
      at com.vmware.exception.converter.ClientExceptionConverter.convertException(ClientExceptionConverter.java:70)
      at com.vmware.rest.client.AbstractRestClient.genericExchange(AbstractRestClient.java:158)
      ...

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Environment

VMware Cloud Director Availability 4.x

Cause

This issue occurs when connection has been lost between Cloud Director Availability and Cloud Director.

Resolution

To log into the Cloud Director Availability Provider Portal, access it via the admin login URL (https://vcda-url/ui/admin) and log in using either root or vSphere SSO credentials.

To resolve this issue, ensure that the Cloud Director instance is healthy and accessible from Cloud Director Availability.
  • Ensure that the Cloud Director cluster, individual cells, and load balancer are healthy.
  • Ensure that the Cloud Director URL used in Cloud Director Availability is reachable from the Cloud Replication Management Appliance over port 443.
  • Re-register Cloud Director in the Settings view of the Cloud Director Availability Provider Portal.