"The provided credentials are not valid." error when configuring replications in Cloud Director Availability 4.x
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"The provided credentials are not valid." error when configuring replications in Cloud Director Availability 4.x

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Article ID: 315037

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:

  • Configuring new replications in Cloud Director Availability fail and you see the error:
The provided credentials are not valid.
  • In the /opt/vmware/h4/cloud/log/cloud.log file on the Cloud Replication Management Appliance, you see entries similar to:
2021-03-09 10:23:59.988 ERROR - [UI-########-####-####-####-##########51-ZL] [job-14] com.vmware.h4.jobengine.JobExecution     : Task ########-####-####-####-##########87 (WorkflowInfo{type='start', resourceType='vmReplication', resourceId='C4-########-####-####-####-##########ae', isPrivate=false, resourceName='null'}) has failed

com.vmware.vcloud.client.exception.VcloudAuthenticationException: null
    at com.vmware.vcloud.client.json.JsonVcloudClient.loginJson(JsonVcloudClient.java:122)
    at com.vmware.vcloud.client.json.JsonVcloudClient.loginJson(JsonVcloudClient.java:164)
    at com.vmware.vcloud.client.auth.JsonCredentialsAuth.login(JsonCredentialsAuth.java:43)
    at com.vmware.rest.client.AbstractRestFactory.acquire(AbstractRestFactory.java:183)
    at com.vmware.rest.client.AbstractRestFactory.acquire(AbstractRestFactory.java:40)
    at com.vmware.resource.health.HealthCheckingFactory$1.acquire(HealthCheckingFactory.java:94)
    at com.vmware.resource.CachedResourceFactory.acquire(CachedResourceFactory.java:106)

2021-03-09 10:23:59.996  WARN - [UI-########-####-####-####-##########51-ZL] [job-14] c.v.h.c.events.ManagementEventsService   : Unable to determine the owner org for task ########-####-####-####-##########87. Fallback to org resolution


Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Environment

VMware Cloud Director Availability 4.x

Cause

This issue can occur when Cloud Director load balancer is not configured for SSL passthrough impacting authentication requests from the Cloud Replication Management Appliance.

Resolution

To resolve this issue, ensure the Cloud Director load balancer has SSL passthrough enabled. Once SSL passthrough is enabled, repair the Cloud Director in the Cloud Director Availability Provider Portal.

For more information, see the Configure to Accept a Renewed VMware Cloud Director Endpoint or Certificate section of the Cloud Director Availability documentation.

Additional Information

When Cloud Director's load balancer is not configured for SSL passthrough, this can also impact the functionality of the Cloud Director Availability plug-in.

For more information, see The Cloud Director Availability plug-in is not visible in the Cloud Director main menu in Cloud Director Availability 4.x.