Upgrading with an ISO image via the management portal fails to complete in Cloud Director Availability 4.0
search cancel

Upgrading with an ISO image via the management portal fails to complete in Cloud Director Availability 4.0

book

Article ID: 315036

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • After upgrading Cloud Director Availability, the UI has updated but the product version has not changed in the About view of the Provider Portal.
  • This issue occurs when updating a Cloud Director Availability 4.0 appliance to a newer version via the management interface using an ISO image.
  • At the end of the /var/log/upgrade.log file, you see entries similar to:
Complete!
Verifying...                          ########################################
Preparing...                          ########################################
        package filesystem-1.1-4.ph3.x86_64 is already installed
Bad exit code: 256
{
    "code": "BadExitCode",
    "msg": "",
    "args": [
        "256"
    ]
}
# Command set-url executing at 2021-07-15 03:00:06.063927
{
    "url": "file:///mnt/cdrom/update/dnf/"
}

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Environment

VMware Cloud Director Availability 4.x

Cause

This issue occurs because the final steps of the upgrade process hangs upon completion and does not perform a required reboot of the system which updates the product version.

Resolution

This is a known issue affecting upgrades from Cloud Director Availability 4.0.

Workaround:
To work around this issue, verify that the /var/log/upgrade.log file ends with the exit code 256 and that the package filesystem-1.1-4.ph3.x86_64 is already installed, then reboot the appliance. Once the appliance has restarted verify that the version has updated in the Provider Portal.