"The recovered VM could not be imported into vCloud Director..." error when performing a failover in Cloud Director Availability 4.x
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"The recovered VM could not be imported into vCloud Director..." error when performing a failover in Cloud Director Availability 4.x

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Article ID: 315031

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:

  • When you failover a replication, the recovered virtual machine fails to import into Cloud Director and you see a message similar to:
The recovered VM could not be imported into vCloud Director. Apply a suitable storage profile to the replication and try again.
  • In the /opt/vmware/vcloud-director/logs/vcloud-container-debug.log on the Cloud Director cell performing the import, you see an entry similar to:

[ UI-cd389a72-c0e3-####-####-########f9a-r504-51-KAJ-kQZ-876c3f2f-e088-####-####-########47d ] The operation failed because no suitable resource was found. Out of 5 candidate hubs:4 hubs eliminated because: Does not contain required resourcepool(s): Resources Rejected hubs: resgroup-1016, resgroup-1012, resgroup-1018, resgroup-10141 hubs eliminated because: Only contains rejected VM Groups(s): [[vCD-Placement-Cairo002007-VM-Group, vCD-Placement-Cairo002006-VM-Group]] Rejected hubs: resgroup-1010- PlacementException NO_FEASIBLE_PLACEMENT_SOLUTION

  • This issue occurs when you have elastic Organization VDCs enabled in the destination Cloud Director instance.
  • This issue occurs when you have VM Placement Policies configured in the destination Cloud Director instance.

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Environment

VMware Cloud Director Availability 4.x

Cause

This issue occurs if the default placement policy of the destination elastic Organization VDC dictates that the recovered virtual machine should be placed on a cluster different to the one where the virtual machine is currently registered in vCenter Server. This results in Cloud Director returning an error that no feasible placement could be found for the recovered virtual machine, causing the import to fail.

Resolution

This is a known issue affecting Cloud Director.
Currently, there is no resolution.


Workaround:

To workaround this issue, ensure you do not have a VM Placement Policy set as the default policy for the target Organization VDC.

To unset the default placement policy:

  1. Log into the Cloud Director Provider Portal as a System Administrator user.
  2. Navigate to Resources > Cloud Resources > Organization VDCs.
  3. Click on the text of the destination Organization VDC.
  4. In the administration view for the Organization VDC, click VM Sizing.
  5. Select a VM Sizing Policy and click Set as default.

Only one compute policy can be set as the default policy per Organization VDC; setting a VM Sizing Policy as the default policy automatically unsets the VM Placement Policy as the default policy.