Accessing Availability view in the Cloud Director Portal automatically logs you out the current Cloud Director session
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Article ID: 315030
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Updated On:
Products
VMware Cloud Director
Issue/Introduction
When you access VMware Cloud Director Availability Portal from the Availability view in Cloud Director, you are automatically logged out of the current Cloud Director session.
In /opt/vmware/h4/cloud/log/cloud.log on the Cloud Replication Management appliance, you see entries similar to:
com.vmware.vcloud.client.exception.VcloudAuthenticationException: null at com.vmware.vcloud.client.VcloudClient.lambda$defaultErrorDeserializer$0(VcloudClient.java:212) at com.vmware.rest.client.AbstractRestClient.convert(AbstractRestClient.java:219) at com.vmware.vcloud.client.XmlRestClient.exchange(XmlRestClient.java:92) at com.vmware.vcloud.client.XmlRestClient.exchange(XmlRestClient.java:68) at com.vmware.vcloud.client.VcloudClient.exchange(VcloudClient.java:179) at com.vmware.vcloud.client.VcloudClient.getResource(VcloudClient.java:930) at com.vmware.h4.cloud.vcloud.VcloudHealthChecker.check(VcloudHealthChecker.java:48) at com.vmware.h4.cloud.vcloud.VcloudHealthChecker.check(VcloudHealthChecker.java:22) at com.vmware.resource.health.HealthCheckingFactory$4.run(HealthCheckingFactory.java:214) at com.vmware.h4.common.mdc.MDCRunnableWrapper.run(MDCRunnableWrapper.java:30) at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264) at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304) at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) at java.base/java.lang.Thread.run(Thread.java:834)
Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.
Environment
VMware Cloud Director Availability 4.x
Cause
This issue can occur when the primary Cloud Director cell in the VCD server group is experiencing issues that impact the Cloud Director Availability health check of Cloud Director.
Resolution
For more information on promoting a standby Cloud Director cell, see the Switch the Roles of the Primary and a Standby Cell in a Database High Availability Cluster section of the Installation, Configuration, and Upgrade Guide
For more information on re-configuring the Cloud Director endpoint, see the Configure to Accept a Renewed VMware Cloud Director Endpoint or Certificate section of the Configure to accept a renewed VMware Cloud Director endpoint or certificateTo resolve this issue, investigate and fix the issues impacting the primary cell of the connected Cloud Director instance.
Workaround: To work around this issue, promote one of the standby Cloud Director cells to be the primary cell or re-configure the Cloud Director endpoint in Cloud Director Availability to point directly to a Cloud Director cell that is not experiencing any issues.