"Bad Request" error occurs when attempting a failover using the vSphere Plug-In in Cloud Director Availability
search cancel

"Bad Request" error occurs when attempting a failover using the vSphere Plug-In in Cloud Director Availability

book

Article ID: 315005

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:

  • Performing a failover from an Cloud Director Availability On-Premises deployment via the vSphere Plug-In fails, and you see the error:
Bad request
  • In the /opt/vmware/h4/cloud/log/cloud.log file on the Cloud Replication Management Appliance, you see entries similar to:
2021-06-21 19:12:06.530 ERROR - [########-####-####-####-########6137-bF] [https-jsse-nio-8046-exec-6] c.v.h.c.c.error.ExceptionAdvisorBase     : A POST request from myaccount@MYSITE[192.2.1.5] to /vm-replications/C4-########-####-####-####-########52bb/failover?site=MYSITE failed.

org.springframework.http.converter.HttpMessageNotReadableException: JSON parse error: Unrecognized field "subnets" (class com.vmware.h4.cloud.api.model.replication.vapp.VAppNetworkSettings$OrgVdcNetwork), not marked as ignorable; nested exception is com.fasterxml.jackson.databind.exc.UnrecognizedPropertyException: Unrecognized field "subnets" (class com.vmware.h4.cloud.api.model.replication.vapp.VAppNetworkSettings$OrgVdcNetwork), not marked as ignorable (2 known properties: "id", "name"])...

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.



Environment

VMware Cloud Director Availability 4.x

Cause

This issue can occur due to an invalid parameter being set when applying network settings for a replication during failover via the Cloud Director Availability vSphere Plug-In.

Resolution

This issue is resolved in Cloud Director Availability 4.2 available at Broadcom Downloads.

Workaround:
To work around this issue, you can initiate the failover from the Cloud Director Availability Tenant and Provider Portals.

Additional Information

Before updating the Cloud Director Availability On-Premises Appliance, confirm that the updated version is compatible with the local underlying infrastructure was well as the peer Cloud Director Availability site: