Unable to access the Cloud Director Availability Portal via the Cloud Director plug-in
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Unable to access the Cloud Director Availability Portal via the Cloud Director plug-in

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Article ID: 315003

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • When accessing Cloud Director Availability Plug-In via Cloud Director, you see a message similar to:
The service at https://VCDA_Public_URL:443 is currently not accessible.
  • In the /opt/vmware/h4/cloud/log directory on the Cloud Director Replication Management Appliance, you see an increasing number of .hprof files being created.
  • You see an increasingly high disk space consumption on the Cloud Director Replication Management Appliance.

Environment

VMware Cloud Director Availability 4.x

Cause

This issue occurs when the Cloud Director Availability Plug-In for Cloud Director tries to authenticate with Cloud Director using an already expired session cookie. This happens when the lifetime of the Cloud Director JSON Web Token and the session cookie lifespans are different.

Resolution

This is a known issue affecting Cloud Director Availability 4.x.
Currently there is no resolution.

Workaround

To workaround this issue, ensure that the idle session timeout and maximum session timeout in Cloud Director are configured with equal values.

  1. Log into Cloud Director as a System Administrator user.
  2. Click on Administration.
  3. Click on General.
  4. Under Timeouts, set Idle session timeout and Maximum session timeout so they are the same value.