Recovered VMs fail to power on while performing a test failover to a cloud site in vCloud Availability
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Recovered VMs fail to power on while performing a test failover to a cloud site in vCloud Availability

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Article ID: 314969

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:

  • When performing a test failover to a cloud site using vCloud Availability, the recovered VM fails to power on.
  • When you try to manually power on the VM from the vCloud Director Tenant Portal, you see the error:
[########-####-####-####-########f842] Unable to perform this action. Contact your cloud administrator.
  • In /opt/vmware/h4/cloud/log/cloud.log on the vApp Replication Manager, you see the following entry:
2019-11-07 03:00:58.495 DEBUG - [UI__########-####-####-####-########39c8_Xw] [task-poller-5] com.vmware.h4.cloud.job.VmFailoverJob    : Failed to power on vapp.DebugInfo = com.vmware.ssdc.library.exceptions.GenericVimFaultException: Underlying system error:
Failed to start the virtual machine.
Module 'DevicePowerOn' power on failed.
Could not set up 'macAddress' for 'ethernet0'.
Invalid MAC address specified.
Impermissible static Ethernet address: '##:##:##:##:##:d7'. It conflicts with VMware reserved MACs.
vCenter Server task (moref: task-1665) failed in vCenter Server 'vc' (########-####-####-####-########06a2)., details = [ ########-####-####-####-########31b0 ] Underlying system error: , taskId = urn:vcloud:task:########-####-####-####-########6948


Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Environment

VMware vCloud Availability 3.0.x

Cause

This issue occurs because the recovered VM is assigned a MAC address that is within the address range allocated for host VMkernel adapters on the underlying vCenter Server system.

Resolution

To resolve this issue, change the MAC address of the VM on failover:
  1. Log into the vCloud Availability Portal for the target site.
  2. In the left pane, under Incoming Replications, click from Cloud or from On-Prem depending on the source of the replication.
  3. Select the protected VM and click the Networks button.
  4. In the Migrate/Failover view of the Network Settings window, select Reset MAC.
  5. Click on the Test Failover button.
  6. In the Test Failover view, selet Reset MAC.
  7. Click Apply.
Perform the test failover again and verify the recovered VM can be powered on.