vCenter is not unregistered from PSC after successful Workload Domain deletion in VMware Cloud Foundation
search cancel

vCenter is not unregistered from PSC after successful Workload Domain deletion in VMware Cloud Foundation

book

Article ID: 314959

calendar_today

Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

Symptoms:
After deleting a Workload Domain in VMware Cloud Foundation, the vCenter Web Client shows that the vCenter license is still being consumed by the old vCenter.

Environment

VMware Cloud Foundation 3.7.x

Cause

This can occur if SDDC Manager is unable to connect to the Platform Services Controller during the Workload Domain deletion workflow, so is unable to completely unregister the vCenter from the PSC.

Resolution

  1. Snapshot all PSCs and all vCenters in the environment.
  2. Open an SSH session to one of the PSCs in the environment.
  3. Execute the following command:
    /usr/lib/vmware-vmafd/bin/dir-cli nodes list
  4. Verify that the vCenter which has already been removed is showing in the output.
  5. Execute the following command:
    cmsso-util unregister --node-pnid <vCenter_FQDN> --username [email protected]


Additional Information

For further information, on decommissioning a vCenter instance, see https://kb.vmware.com/s/article/2106736

Impact/Risks:
Unregistering a vCenter from a PSC is an irreversible process. Ensure that snapshots are taken of all vCenters and PSCs in the environment before proceeding.