Various content missing and 500 errors in the UI after recently upgrading Aria Automation
search cancel

Various content missing and 500 errors in the UI after recently upgrading Aria Automation

book

Article ID: 314892

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Aria Automation has recently been upgraded, despite the process completing successfully when accessing the Cloud Assembly and Service Broker components the content is missing and 500 errors are visible in the UI.
  • If you open the web browser developer tools when navigating the UI the following error can be seen:
Unable to convert claim 'iss' of type 'class java.lang.String' to URL.
  • The same exception is also visible in the service logs for example the catalog service log file located under /var/log/services-logs/prelude/catalog-service-app/file-logs/catalog-service-app.log contains errors similar to:
ERROR catalog-service-app [host='catalog-service-app-759f857797-nvknz' thread='http-nio-8000-exec-5' user='' org='' trace=''] o.a.c.c.C.[.[.[/].[dispatcherServlet] - Servlet.service() f
or servlet [dispatcherServlet] in context with path [] threw exception
java.lang.IllegalArgumentException: Unable to convert claim 'iss' of type 'class java.lang.String' to URL.
 

 


Environment

VMware Aria Automation 8.x
VMware vRealize Automation 8.x

Cause

The issue is caused by a malformed token.

Resolution

The issue is pending a resolution.

Workaround:
To workaround the issue logout from the Aria Automation UI with the affected user, clear the browsers cache and log back in again.