"No upgrade available" showing in Aria Suite Lifecycle 8.12 when upgrade fails during download of upgrade rpms
search cancel

"No upgrade available" showing in Aria Suite Lifecycle 8.12 when upgrade fails during download of upgrade rpms

book

Article ID: 314842

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • "No upgrade available" showing in Aria Suite Lifecycle when initial upgrade attempt fails
  • The /var/log/vmware/capengine/cap-non-lvm-update/workflow.log indicates the failure occurs when downloading packages:

YYYY/MM/DD HH:MM:SS task_progress.go:24: Downloading package [45/112]. Package name: cap-applmgmt , version: {204 1.4.0}
YYYY/MM/DD HH:MM:SS stage_plugin.go:464: Failed to download https://vapp-updates.vmware.com/vai-catalog/valm/vmw/<UID>/8.14.0.4/package-pool/cap-applmgmt-1.4.0-204.x86_64.rpm. Error: exit status 4. Output:
YYYY/MM/DD HH:MM:SS progress.go:11: Failed to stage updates
YYYY/MM/DD HH:MM:SS task_progress.go:24: Failed to stage updates
YYYY/MM/DD HH:MM:SS workflow_manager.go:217: Task stage failed. Error: exit status 4

 

Environment

VMware Aria Suite Lifecycle 8.x

Cause

The issue occurs when the Aria Suite lifecycle upgrade fails during package download.

Resolution

The issue is pending a resolution.

Workaround:

To workaround the issue perform the following:

1. Revert to the pre-upgrade snapshot and retry the upgrade

If no pre-upgrade snapshot exist or if the issue persists proceed with steps 2-5:

2. Snapshot again the Aria Suite Lifecycle appliance.

3. Take a backup of the update_status.json file:
cp /etc/vmware/cap/cap_am/update_status.json /etc/vmware/cap/cap_am/update_status.json.backup

4. Remove the original update_status.json file:
rm /etc/vmware/cap/cap_am/update_status.json

5.Attempt Upgrade again via CDROM