"Access is denied" banner when opening deployment in Aria Automation 8.16.1
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"Access is denied" banner when opening deployment in Aria Automation 8.16.1

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Article ID: 314731

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • "Access is denied" banner when opening deployment in Aria Automation 8.16.1
  • The issue only affects regular users, administrator users are not affected. The issue is cosmetic in nature there is no functional impact.
  • The /var/log/services-logs/prelude/tango-blueprint-service-app/file-logs/tango-blueprint-service-app.log logfile contains an Access is denied exception similar to:

 2024-03-20T11:16:10.865Z ERROR tango-blueprint [host='tango-blueprint-service-app-<ID>' thread='http-nio-8080-exec-5' user='<Username>' org='<OrgID>' trace='<TraceID>']com.vmware.tango.blueprint.exception.ControllerExceptionHandler - Access denied exception: org.springframework.security.access.AccessDeniedException: Access is denied


Environment

VMware Aria Automation 8.16.x

Cause

When any user opens a deployment, the UI tries to download the cloud template from which it was created. If you are an admin it works as designed, you have a download button next to the cloud template field. However if you are a normal user you see a 403 access is denied error. The issue arises as the deployment UI has a defect which shows the error to the user instead of silently handling it.

Resolution

The issue is resolved in the Aria Automation 8.16.2 release.