Upgrade fails for Aria Automation 8.12 multi-tenant environments affected by branding issue outlined in KB92018
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Upgrade fails for Aria Automation 8.12 multi-tenant environments affected by branding issue outlined in KB92018

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Article ID: 314727

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • The upgrade fails for Aria Automation 8.12 multi-tenant environments affected by branding issue outlined in KB92018.
  •  The /services-logs/prelude/identity-service-app/file-logs/identity-service-app.log file contains a service definition already exists error:
2023-05-30T11:37:08.178Z WARN identity-service [host='identity-service-app-7d48df8488-r72fw' thread='jdbc-10' user='prelude-gQOACDwGKd:prelude-gQOACDwGKd (7f392c68-7981-4051-bcf7-e159abd9dc5d)' org='csp' trace
='bba5048b-2775-4a2f-8941-52fd7c7e2b03'] c.v.a.s.w.p.s.util.SqlRetryableUtil.causeIsRecoverable:349 - Retry ID [n/a] - Non Recoverable SQL exc
        com.vmware.identity.exception.ResourceAlreadyExistsException: Service definition with display name 'Assembler' already exists.
  • The /var/log/deploy.log file will have a curl failure with a 409 response and the deployment will fail:
curl: (22) The requested URL returned error: 409
curl: (3) URL using bad/illegal format or missing URL
Deployment failed. Collecting log bundle ... 


Environment

VMware Aria Automation 8.12.x

Cause

The issue occurs when an upgrade is attempted on a multi-tenant Aria Automation 8.12 environment affected by KB92018 before the resolution steps outlined in the knowledge base article are performed.

Resolution

To resolve the issue:

1. Revert to backups taken prior to initiating the upgrade.
2. Apply the resolution steps from KB92018.
3. Initiate again the upgrade.