Actions bound to the value of inputs in custom forms fail with null values in Aria Automation 8.14
book
Article ID: 314723
calendar_today
Updated On:
Products
VMware Aria Suite
Issue/Introduction
Symptoms:
Actions that are bound to the value from inputs in custom forms are called twice in Aria Automation 8.14 the initial execution has null values, the second execution contains the expected values
For example you have a simple workflow which takes a "VC:VirtualMachine" object type as input. You create a custom day 2 action based on this workflow which has an action in the custom form which takes this "VC:VirtualMachine" object type as input. The action gets called twice failing on the initial run due to null values with an error similar to:
"cannot get value from null"
The same configuration executes successfully on version 8.13 without the null errors
Environment
VMware Aria Automation 8.14.x
Cause
Custom form actions that uses the value from inputs are called twice. On the first request there is an error due to null values being passed.
Resolution
The issue is scheduled to be resolved in the Aria Automation 8.14.1 release
Workaround: To workaround the issue you can modify the action script to validate the input before using it, the error will not be thrown and the field will be populated by the second call.
For example:
if (!<input>) {
return <empty>; // depends on the return type - string, array and so on }