Changes to enabled features such as Support requests and feedback under help panel are not persisted in multi-tenant Aria Automation environments
search cancel

Changes to enabled features such as Support requests and feedback under help panel are not persisted in multi-tenant Aria Automation environments

book

Article ID: 314713

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:

Changes to enabled features such as Support requests and feedback under help panel are not persisted in multi-tenant Aria Automation environments.

image.png


Environment

VMware Aria Automation 8.12.x

Cause

When saving options, the code checks if previous options exist. If not, we skip the save instead of creating an empty object and save to that.

Resolution

The issue is planned to be resolved in the Aria Automation 8.13.1 release

Workaround:

To workaround the issue its possible to update the options via curl Api. As best practice precaution snapshot the Aria Automation appliance(s) before proceeding:

1. Login to the affected tenant and open Developer tools and the Network tab in the web browser.
2. Clear network tab tab so that its empty.
3. Save the UI, this will generate output in the Network tab. Use the Preserve log checkbox to persist entries.
4. Select the first call
5. Copy as curl

image.png

6. Next, edit that curl command to have the correct option settings like this:
"options":{"communitiesLink":"","disableFeedback":true,"disableSupportRequests":true}

7. Then run the curl in a command prompt, and verify support options are hidden.