NSX-T Manager root/admin/audit account disconnected in SDDC Manager password management
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Article ID: 314637
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Updated On:
Products
VMware Cloud Foundation
Issue/Introduction
- This article outlines the steps to mark the status to ACTIVE for disconnected accounts in SDDC Manager Password Management.
- NSX-T Manager / Backup account disconnected in SDDC Manager password management
Cause
- Password is expired
- Mismatch between password stored in SDDC and the actual password
Resolution
To resolve the issue, Remediate the password for the account in SDDC Manager
Follow the below steps
- Take SSH to SDDC Manager with vcf user and su to root
- Get the password for the NSX-T Manager accounts
- Run the command lookup_passwords and enter the entity type as NSXT_MANAGER
Or
- Use API (SDDC Manager > Developed Center > API Explorer > Credential > GET /v1/credentials > resourceType - NSXT_MANAGER > Execute
- SSH to NSX-T Manager with admin account
- Check the expiry of the account with the below command
get user root password-expiration
- Set the root password to match with the password output from Step # 2
set user root password
- Remediate the same password in SDDC Manager
The above steps applies for NSX-T Edge nodes too.
Additional Information
Impact/Risks:
NONE - The steps provided are safe to run with no downtime on any of the components involved.
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