NSX-T Manager / Backup account disconnected in SDDC 4.5 password management
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Article ID: 314637
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Updated On:
Products
VMware Cloud Foundation
Issue/Introduction
This article outlines the steps to mark the status to ACTIVE for disconnected accounts in SDDC Manager 4.5 Password Management.
Symptoms:
NSX-T Manager / Backup account disconnected in SDDC 4.5 password management
Environment
Vmware Cloud Foundation 4.5
Cause
- Password is expired
- Mismatch between password stored in SDDC and the actual password
Resolution
To resolve the issue, Remediate the password for the account in SDDC Manager
- Get an SSH session to the SDDC Manager using the vcf account and the su to root.
- Run the command lookup_passwords and list the password(s) for the disconnected account(s) - e.g backup & nsxt_manager
- Change the password in the component for the disconnected account to match with what is stored in SDDC
- For NSX-T Manager:
- Get an SSH session to the NSX-T manager using the admin account
- Edit the password of account:
- For BACKUP:
- Get an SSH session to the SDDC manager using the vcf account and the su to root.
- Run the command passwd backup and change the password to match with the output listed earlier.
- Login to the SDDC Manager UI > Password Management and select the disconnected account
- Click on the 3 dots and click on REMEDIATE
- Remediate with the same password which listed in lookup_passwords.
- Restart SDDC Manager services using the command: /opt/vmware/vcf/operationsmanager/scripts/cli/sddcmanager_restart_services.sh
Additional Information
Impact/Risks:
NONE - The steps provided are safe to run with no downtime on any of the components involved.
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