Bundle Management page does not load, Upgrades for MGMT Workload Domain not visible
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Bundle Management page does not load, Upgrades for MGMT Workload Domain not visible

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Article ID: 314618

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

  • Upgrade API calls are timed out
  • From the SDDC UI, the Bundle Management page does not load and is unable to access available bundles for the MGMT domain.
     

  • From the SDDC UI, the following error message appears:

    Retrieving all applicable bundles failed. Http failure response for https://<VC_fqdn>/ui/api/internal/lcm/repository/true: 504 Gateway Time-out

Environment

VMware Cloud Foundation 4.1

Cause

Existence of many versions of manifest files in the backup can cause timeouts when parsing through all of them. LCM has to filter out the latest one after accessing all the available manifest files.

Resolution

This issue is resolved in VCF 4.3.

Additional Information

Impact/Risks: Since a database edit is required to remove older versions of the manifest files, a snapshot of the SDDC manager is recommended.

Workaround

  1. Take a snapshot of SDDC manager
  2. SSH to the SDDC Manager with vcf user and then su root.
  3. Access the database

    psql -h localhost -U postgres -d lcm

  4. View the contents from the manifest

    select id,version,sequence_number from manifest;

    Example



  5.  If there are multiple records for the same version, delete all entries except the highest sequence number.

    delete from manifest where sequence_number < <highest_sequence_number> and version=<version_number>;

  6. Exit the database

    \q



  7.  Restart the LCM service

    systemctl restart lcm