Smarts: Interface status of NOTPRESENT in the Availability Manager (AM) Topology Browser causing Interface Down notification in Service Assurance Manager (SAM)
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Smarts: Interface status of NOTPRESENT in the Availability Manager (AM) Topology Browser causing Interface Down notification in Service Assurance Manager (SAM)

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Article ID: 314570

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:




Interface status of NOT PRESENT in the Availability Manager (AM) Topology Browser causing Interface Down notification in Service Assurance Manager (SAM).

Environment

VMware Smart Assurance - SMARTS

Cause

This issue is related to the SNMPAgent on a device running SNMP version V1. When the IP server gets an error from a V1 SNMPAgent on a device, rather than repoll all the OIDs on the device, it takes the Interface object associated to that Interface Index in the MIB which returned the error off the SNMP Poller. This prevents the SNMP Poller from repelling all the OIDs and potentially causing the device to go into a high CPU state making it unusable. The Interface will remain Managed but will not be automatically SNMP Polled, leaving the last value in the instrumentation "Not Present," which generates an Interface Down Notification.

Resolution

To resolve this issue, do the following:
  1. Find out which version of SNMP the agent on the device is running using the following:

    <BASEDIR>/smarts/bin/dmctl -s <AMserver> get SNMPAgent::SNMPAgent-<devicename>::SNMPVersion
     
  2. If the device SNMPAgent is SNMP version V1, the best option is to upgrade the SNMPAgent on the device to SNMP V2c. If this upgrade is not possible, do one of the following options. 
Option A : Manually reinsert Interfaces back in SNMP Poller (recommended)
On the Interface(s) with a NOTPRESENT status, Unmanage, Manage and then execute a Reconfigure. This series of operations will insert the Interface back into the SNMP Poller, and its status will update until a reoccurrence of the SNMP Polling error.
Option B: Change default behavior so SNMP polling for V1 continues automatically (see CAUTION)
 
CAUTION This change may cause device to go into a high CPU utilization state if SNMP polling retries continue to send numerous SNMP get requests to every OID on the device after an error was encountered.
To change the default SNMP V1 polling behavior and use this option, do the following:
  1. Stop the IP server.
  2. Launch the runcmd_env.sh as follows:

    <BASEDIR>/InCharge6/IP/smarts/local/conf/runcmd_env.sh
     
  3. Insert the following variable in the runcmd_env.sh:

    SM_SNMP_ALWAYS_ABLE_TO_POLL=TRUE
     
  4. Restart the IP server.