Smarts: Unable to start Broker; Logs show "CI-NOADDR-No address available for address family" messages
search cancel

Smarts: Unable to start Broker; Logs show "CI-NOADDR-No address available for address family" messages

book

Article ID: 314553

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:


Unable to start Smarts Broker, and the log file reports errors such as  CI-NOADDR-No address available for address family AF_INET.; in file, RSRV-E-EBRSTART-Cannot start Broker, and HTTP-NOFLOW-Could not create any listener flows (see log for details); in file

Error in the Smarts domain log:
CI-NOADDR-No address available for address family 

Smarts Broker log reports the following error: 
HTTP-E-FPF-No HTTP listener configured on IPv4, because:
CI-NOADDR-No address available for address family AF_INET

RSRV-E-EBRSTART-Cannot start Broker
HTTP-NOFLOW-Could not create any listener flows (see log for details); in file "/work/tancurrent/DMT-9.3.0.0/116/smarts/http/sm_httpd.c" at line 639


Environment

VMware Smart Assurance - SMARTS

Cause

Broker host configuration is incorrect. There is no entry in the etc/hosts file for the localhost and hostname

Resolution

If you encounter this issue, do the following:
  1. Check the interface configuration (ifconfig) by running the following command on the host:
ifconfig -a
 
  1. If localhost is being used to start up the Smarts Broker, check the /etc/hosts file and ensure that has the correct information for the localhost and hostname.
  2. Once you are sure the configuration is correct, restart the Smarts Broker.
     


Additional Information

Additional debugging can be initiated on the broker by adding the --tracelevel=Debug to the startup command

./brstart --port=7664 --tracelevel=Debug --output=broker_test --daemon