The ESXi/ESX host logs report the message: IPMI message handler: BMC returned incorrect response
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The ESXi/ESX host logs report the message: IPMI message handler: BMC returned incorrect response

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Article ID: 314381

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • In the /var/log/vmkernel (ESX) or /var/log/messages (ESXi) log file, you see an entry similar to:

    IPMI message handler: BMC returned incorrect response, expected netfn A cmd XX, got netfn B cmd YY

    Note: For more information, see Location of log files for VMware products (1021806).


Environment

VMware vSphere ESXi 6.5
VMware vSphere ESXi 5.0
VMware vSphere ESXi 6.7
VMware vSphere ESXi 5.1
VMware ESXi 4.1.x Installable
VMware vSphere ESXi 6.0
VMware ESX 4.1.x
VMware vSphere ESXi 5.5
VMware ESXi 4.1.x Embedded

Cause

This message indicates that the response received from the Baseboard Management Controller (BMC) does not match the request that was issued.

This issue may occur if the CIM and IPMI components in ESXi/ESX 4.x lose synchronization with the hardware BMC, for example, when the BMC firmware is flashed or reset. The host may lose synchronization with the hardware BMC when another software or hardware client makes a conflicting request of the BMC or due to a hardware or software defect that leads to erroneous requests and/or responses.

Note: For related information, see IPMI logs in ESX/ESXi 4.x consume excessive disk space after a BMC reset or firmware update (2000089).

Resolution

If these messages are reported occasionally in the log files, you can safely ignore them. However, if the log file contains a log spew of this message, they may be symptomatic of an underlying issue. In this case, try one of the options:

  • Update the BMC firmware and system BIOS to the latest version. For more information, consult your hardware vendor.
     
  • Update the IPMI driver and SFCB CIM components on the ESX/ESXi host to the latest version. Search the knowledge base and the Patch Download Center for IPMI and CIM patches.
     
  • If the hardware health status information is not required or used, disable the CIM agent on the host. For more information, see How to disable the CIM agent on the ESX/ESXi host (1025757).


Additional Information

For more information, see Host Hardware status intermittently displays the alert: Processor 2 Status 0: IERR (1025055).
Location of log files for VMware products
Host Hardware status intermittently displays the alert: Processor 2 Status 0: IERR
IPMI logs in ESX/ESXi 4.x and ESXi 5.0 consume excessive disk space after a BMC reset or firmware update
ESXi/ESX ホストのログに次のメッセージが表示される: IPMI message handler: BMC returned incorrect response
ESXi/ESX 主机日志报告消息:IPMI message handler: BMC returned incorrect response