Intermittent Host CPU spikes are seen when using Veeam Volume Backups with Nimble Storage Array
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Intermittent Host CPU spikes are seen when using Veeam Volume Backups with Nimble Storage Array

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Article ID: 314348

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Updated On: 05-21-2025

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:

  • There may be intermittent CPU spikes to 100% on the host, due to leftover Nimble Snapshots.
  • Tasks such as host compliance checks or exporting host logs may also trigger CPU spikes.
  • vmkernel.log may show the following:

[YYYY-MM-DDTHH:MM:SS] cpu18:2098344)WARNING: NMP: nmp_PathDetermineFailure:3527: Cmd (0x9e) PDL error (0x5/0x25/0x0) - path vmhba1:C0:T1010:L01 device eui.60060060660########60606- triggering path failover
[YYYY-MM-DDTHH:MM:SS] cpu18:2098344)WARNING: NMP: nmpCompleteRetryForPath:394: Logical device "eui.60060060660########60606": awaiting fast path state update before retrying failed command again...
[YYYY-MM-DDTHH:MM:SS] cpu3:9757009)WARNING: VMW_SATP_ALUA: satp_alua_issueInquiry:83: Target completed the Inquiry VPD Page 0x83 request with good status but returned junk data for path vmhba#:C0:T##:L##
[YYYY-MM-DDTHH:MM:SS] cpu3:9757009)WARNING: VMW_SATP_ALUA: satp_alua_getTargetPortInfo:160: Could not get page 83 INQUIRY data for path "vmhba1:C0:T10:L01" - Failure (195887105)

Environment

vSphere ESXi 7.0.x

Cause

The issue may be due to leftover Nimble snapshots:
"Veeam asks the array to take a snapshot for backup. If the ESXi host does a re-scan, it will see the online snapshot as a device. When Veeam asks the array to delete the snapshot, VMware will lose access to the device and report a Permanent Device Loss (PDL).

The ESXi host, believing the device is still available, retries all SCSI commands indefinitely. This has an impact on the management agents such as hostd, vpxa etc, as their commands are not responded to until the device is again accessible. This causes the ESXi host to become Not Responding in the vCenter Server or have performance issues with tasks getting queued.

Resolution

This is not a vSphere issue. Please engage the Storage array vendor for resolution.
Link: https://helpcenter.veeam.com/docs/backup/vsphere/nimble_add_name.html?ver=120