VMware NSX 4.1.0 UI becomes inaccessible after login due to language setting
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VMware NSX 4.1.0 UI becomes inaccessible after login due to language setting

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Article ID: 314272

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Updated On:

Products

VMware NSX

Issue/Introduction

  • You have deployed or upgraded to VMware NSX 4.1.0.
  • The cluster is reporting STABLE, confirmed using the "get cluster status" command from the admin CLI on an NSX manager node.
  • After you login to the NSX UI it becomes unresponsive as per the below screenshot:
  • Using the DevTool (by pressing F12 in Google Chrome) you see the following "Unhandled Promise rejection" error:
Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.



Environment

VMware NSX-T

Cause

The is due to the language set in the browser. NSX has been localized into multiple languages: English, German, French, Japanese, Simplified Chinese, Korean, Traditional Chinese, Italian, and Spanish.
Because NSX localization utilizes the browser language settings, if the language differs from the above the UI will fail to load.

Resolution

This issue has been resolved in VMware NSX 4.1.1 available at Broadcom downloads.

Workaround:
To workaround the issue change the language of the browser to one of the supported languages below:
English, German, French, Japanese, Simplified Chinese, Korean, Traditional Chinese, Italian, and Spanish