NTP connectivity error in the system health section on Cloud Director Availability 4.x
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NTP connectivity error in the system health section on Cloud Director Availability 4.x

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Article ID: 314268

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • In the system health section of any of the Cloud Director Availability services you can see an error under NTP configuration.
  • To confirm you are facing this issue you can follow this steps:
  1. SSH to the affected appliance.
  2. Login using the root account and password
  3. run: systemctl status systemd-timesyncd.service
  • on the previous command you see entries similar to:
Server has too large root distance. Disconnecting.


Environment

VMware Cloud Director Availability 4.x

Cause

This issue occurs when the NTP server has too large of a root distance to the appliance to properly synchronize the time based on the systemd-timesync.service default values

Resolution

To resolve this issue move the appliances closer to the NTP server so the root distance decreases.

Workaround:
To workaround this issue you can increase the default maximum root distance allowed by the systemd-timesync service
  1. SSH to the affected appliance.
  2. Login using the root account and password
  3. Backup the timesyncd.conf
cp /etc/systemd/timesyncd.conf /etc/systemd/timesyncd.conf.bkp
  1. vi /etc/systemd/timesyncd.conf
  2. Remove the "#" in front of the line #RootDistanceMaxSec=5
  3. Increase RootDistanceMaxSec=5 to RootDistanceMaxSec=30
  4. Save the changes using ":wq!"
  5. Restart the systemd-timesync.service
systemctl restart systemd-timesync.service
  1. After 30 seconds refresh the Cloud Director Availability service UI in the browser and confirm the NTP error is gone.