HCX-Manual removal of a Service Mesh and Compute Profile in 4.3
search cancel

HCX-Manual removal of a Service Mesh and Compute Profile in 4.3

book

Article ID: 314195

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

Attempting to delete a Service Mesh form the HCX manager UI using the Service Mesh force delete option may fail.


Environment

HCX

Cause

The Service Mesh entry may not be deleted even when the force delete option is used. This may be the result of failed configuration workflows such as manually deleting the HCX manager and appliances from the remote site instead of following the documented HCX removal procedures. Proper analysis and troubleshooting should be performed to identify the cause.

Resolution

IMPORTANT: Manual removal of a Service Mesh or Compute Profile should be considered only as a last resort. The following steps should be performed before attempting to manually remove the entry.

Service Mesh:

  • From the HCX Manager UI, ensure that no Disaster Recovery operations or Migrations are running for the Service Mesh.
  • Remove all Network Extensions for the Service Mesh.
  • Follow the documented HCX Service Mesh removal procedure which involves initiating the Service Mesh removal from the Connector site. This in turn will remove the Service Mesh and associated HCX appliances from both the Connector and Cloud sites. The process requires that HCX is fully functional, including site pairings and communication between source and destination site appliances.
  • If the remote site HCX appliances associated with the Service Mesh and/or HCX Manager have already been permanently removed for some reason then use the Service Mesh force delete option. This option will remove the HCX appliances associated with the Service Mesh and the Service Mesh itself even if the remote site cannot be reached.
  • If the Service Mesh force delete is failing, attempt to restart (stop then start) application services via the HCX Manager Appliance Management UI (https://hcx-manager-ip-or-fqdn:9443) after logging in as admin.

Compute Profile:

  • Ensure that the Compute Profile is not in use by any Service Mesh.
  • Delete the Compute Profile from the HCX Manager UI.


If the above steps do not resolve your issue, please proceed with gathering the below details and create a support request with Broadcom.

  • Provide HCX version for each connected site
  • Attempt to recall steps performed to remove service-mesh and compute-profile and what errors where thrown
  • Provide a time-stamp and error for the latest attempt to remove service-mesh and compute-profile.
  • Provide this Article ID# 314195

Additional Information

HCX - Manual removal of a Service Mesh and Compute Profile PRE 4.3

Impact/Risks:
If an attempt is being made to remove an HCX Service Mesh the assumption is that the service is no longer required and so the impact / risk is minimal