Aria Automation Inventory Sync Fails because a password does not exist - displaying Error Code: LCMVCF19102
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Aria Automation Inventory Sync Fails because a password does not exist - displaying Error Code: LCMVCF19102

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Article ID: 314169

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:

  • Aria Automation or other product inventory sync with VMware Aria Lifecycle Manager (vRLCM) fails. The sync does not complete, and the following error is observed:
    • Error Code: LCMVCF19102
      Error Message: Exception occurred while registering product with SDDC Manager inventory. Password with VMID <VMID> does not exist when registering product with SDDC Manager <SDDC Manager hostname>.
  • The error suggests that a required VMware Cloud Foundation (VCF) user account password is missing in the Aria lifecycle manager locker.
  • The following error may be seen in the LCM logs:
    • Password YXYXYXYXYX vmid ID1 does not exists. 
      com.vmware.vrealize.lcm.common.exceptions.passwordDoesNotExistException: Password with vmid ID2 does not exit
    • The vmids ID1 and ID2 mentioned above are different IDs in the same error message.

Environment

  • VMware Aria Automation Version: 8.x
  • VMware Aria Lifecycle Manager Version: 8.x

Cause

This issue occurs because the VCF user account password required for syncing is not present in the Aria lifecycle manager locker. The password must be registered for the inventory sync to complete successfully.

Resolution

Resolution Option 1:

  1. Add new password item to the locker,
  2. Trigger Inventory Sync on any product which has broken password assigned in LCM
  3. Assign the new password item to this product (even if the password is identical to another in the Locker - this does not matter.) 

 

Resolution Option 2:

1. Create a VCF User Account in the Aria lifecycle manager Locker:

In the Aria Lifecycle Manager UI, create a new password entry for the VCF user account in the Locker section.

2. Identify the VMID:

After creating the password entry, click on the newly created user account.
Take note of the VMID from the browser's address bar. It should appear like this:
https://{VRLCM}/lcm/locker/password/32160f37-4a40-4c63-92f8-103449d47b91.

3. Backup Aria lifecycle manager Database:

Before proceeding with any database changes, please go ahead and take a snapshot of the Aria lifecycle manager Appliance

4. Run the Database Update Query:

Open an SSH session to lifecycle manager and execute the following commands:

cd /opt/vmware/vpostgres/11/bin
su postgres
./psql -d vrlcm

5. Run the following query to update the VMID in the database:

UPDATE vm_locker_password set vmid = '<VMID-1>' where vmid = '<VMID-2>';

Where:
<VMID-1> is the VMID from the error message.
<VMID-2> is the VMID found in the address bar when you clicked on the VCF user account.

Example Query:

UPDATE vm_locker_password set vmid = 'fe5cafa1-8af1-482f-9a9c-1e33aa512d6' where vmid = '32160f37-4a40-4c63-92f8-103449d47b91';

6. Exit the Database:

\q
exit

7. Retry the Product Inventory Sync:

Once the database update is complete, go back to the Aria lifecycle manager UI and click "Retry" on the product inventory sync.

Additional Information

 

Always ensure you have a backup before making any changes to the vRLCM database.
Refer to the log files at /var/log/vrlcm/vmware_vrlcm.log for further troubleshooting if the issue persists.
This issue is specific to environments where Aria lifecycle manager and Aria Automation are integrated with VMware Cloud Foundation (VCF).