VMware HCXVMware Cloud on AWSVMware Cloud on Dell EMC
Issue/Introduction
Symptoms: A duplicate network is present (not connected to VMs or ESXi hosts).
The VMC Networking & Security UI only shows one instance of the network whereas vCenter Server shows two. This can be seen after the customer's environment underwent n-VDS to c-VDS migrations.
Cause
This can be caused by the following reasons: • If there is a snapshot attached to a VM. • If there is no snapshot, there are VM templates referencing the network segment and hence is not associated with any of the hosts.
Resolution
If there are snapshots attached to the VM, proceed with consolidating the snapshot chain. You may have to delete the snapshot(s) if snapshot consolidation does not work.
If there are no snapshots, proceed with checking VM templates:
Delete these templates and the network duplicate entry will disappear from the VC.
Delete the reference to the duplicate network segment (and use a valid NSX managed segment if required) in these VM templates and that will also cause this segment to disappear from the VC. One may have to create a new VM from these templates, update the VM settings to point to an empty (or correct) network and create a new template from the VM while deleting the old VM template.
Additional Information
Impact/Risks: This is expected behavior on part of the vCenter Server.