Error: "the virtual disk is either corrupted or not a supported format" when committing or creating snapshots
book
Article ID: 314034
calendar_today
Updated On:
Products
VMware vCenter Server
VMware vSphere ESXi
Issue/Introduction
Move all the
CTK files to a temporary folder to resolve this issue.
Symptoms:
- Committing snapshots, either from the GUI or the console, fails with the error:
Remove all snapshots VM_NAME the virtual disk is either corrupted or not a supported format
- Creating snapshots, either from the GUI or the console, fail with the error:
Create VM snapshot VM_NAME the virtual disk is either corrupted or not a supported format
- When the snapshots are committing, the CTK files are not accessible.
- The vmware.log file on the virtual machine contains entries similar to:
[YYYY-MM-DDTHH:MM:SS]: vmx| SNAPSHOT: SnapshotConsolidateOpenDisks failed: Could not open/create change tracking file.
[YYYY-MM-DDTHH:MM:SS]: vmx| DISKLIB-CBT : Shutting down change tracking for untracked fid 307069440.
[YYYY-MM-DDTHH:MM:SS]: vmx| DISKLIB-CBT : Successfully disconnected CBT node.
[YYYY-MM-DDTHH:MM:SS]: vmx| DISKLIB-VMFS : "/vmfs/volumes/4ab1b163-2c802f26-5a4f-00219b929667/Persia/Persia-000023-delta.vmdk" : closed.
[YYYY-MM-DDTHH:MM:SS]: vmx| DISKLIB-VMFS : "/vmfs/volumes/4ab1b163-2c802f26-5a4f-00219b929667/Persia/Persia-000021-delta.vmdk" : closed.
[YYYY-MM-DDTHH:MM:SS]: vmx| DISK: Failed to open disk for consolidate '/vmfs/volumes/4ab1b163-2c802f26-5a4f-00219b929667/Persia/Persia-000023.vmdk' : Could not open/create change tracking file (2108) 4700
- Files in the virtual machine folder on the datastore appear to be locked or corrupt.
Environment
VMware vSphere ESXi 6.7
VMware vSphere ESXi 5.0
VMware ESX 4.0.x
VMware ESXi 4.1.x Installable
VMware vCenter Server 4.1.x
VMware vSphere ESXi 5.5
VMware ESXi 4.0.x Embedded
VMware ESXi 4.1.x Embedded
VMware vCenter Server 5.0.x
VMware vCenter Server 6.7.x
VMware ESXi 4.0.x Installable
VMware ESX 4.1.x
VMware vCenter Server 5.1.x
VMware vCenter Server 4.0.x
VMware vCenter Server 5.5.x
VMware vSphere ESXi 7.0.x
VMware vSphere ESXi 8.0.x
Cause
This issue is caused by corrupt CTK files in the virtual machine folder.
Resolution
To resolve this issue, move all of the CTK files into a temporary folder.
Note: In the virtual machine folder, the CTK file is associated with each delta disk and flat file for that virtual machine.
To move all of the CTK files into a temporary folder:
- Power off the virtual machine.
- Create a temporary folder in the virtual machine folder.
- Move all of the CTK files into the temporary folder.
- Right-click the virtual machine and select Snapshot > Snapshot Manage to consolidate the snapshots for the virtual machine.
- Click Delete All.
- Click Close.
Feedback
thumb_up
Yes
thumb_down
No