VCSA 6.5 で、複数の電子メールがセミコロンで区切られているとアラーム アクションから通知電子メールを送信できない
search cancel

VCSA 6.5 で、複数の電子メールがセミコロンで区切られているとアラーム アクションから通知電子メールを送信できない

book

Article ID: 314024

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
免責事項: これは英文の記事「Unable to send a notification email from Alarm action if multiple emails are separated by semicolon in VCSA 6.5 (2150106) 」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

PowerCLI を使用して複数の電子メール アドレスに通知メールを送信するようにアラーム アクションが設定されている場合、vCenter Server Appliance でアラームがトリガーされると、指定した受信者に電子メールが送信されない。

Environment

VMware vCenter Server Appliance 6.5.x

Cause

PowerCLI を使用してアラーム アクションに複数の電子メールを設定すると、デフォルトでセミコロン (;) を区切り文字として電子メールは [宛先] フィールドに追加されます。しかし、VMware vCenter Server Appliance (VCSA) 6.5 では区切り文字にはコンマ (,) しか使用できないため、電子メールの送信が正常に実行されません。

Resolution

この問題を解決するには、次の手順を実行します。
  1. vCenter のアラーム アクションの設定で、セミコロン (;) を手動でカンマ (,) に置換します。電子メールによるアラーム通知が正常に送信されます。
  2. 次のサンプル スクリプトを使用して、電子メールごとに個別のアラーム アクションを設定します。
-----------------------------------
$emails = @('[email protected]', '[email protected]' )
foreach ($email in $emails)
{
Get-AlarmDefinition -Name "Storage DRS recommendation" | New-AlarmAction -Email -To $email
}
-----------------------------------