Workload Management Displays an Error code 500 when POSTing to NSX Manager
search cancel

Workload Management Displays an Error code 500 when POSTing to NSX Manager

book

Article ID: 313952

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
Workload Management a "configuring status" with an error that looks similar to the below screenshot:
error500.png
You are unable to login to the supervisor cluster and receive an internal server error when trying to do so.
 


Environment

VMware vCenter Server 7.0.3
VMware vCenter Server 8.0

Cause

The compute manager for the vCenter within NSX-T is down and not responding to API calls.

Resolution

To resolve this issue you will need to recreate the trust between vCenter and the compute manager on NSX-T.
  1. Log into NSX-T as admin
  2. Navigate to system -> fabric -> compute managers
  3. Locate the compute manager that corresponds to the vCenter server hosting your supervisor cluster
  4. Toggle the radio button for it and select "edit"
  5. Disable the "enable trust" slider and click "save"
  6. Edit the compute manage once more, re-enable "enable trust" option
  7. Before saving, click the "edit" button next to FQDN or IP address field and input the SSO administrator credentials for vSphere
  8. Click "save"
You may need to refresh the page to ensure the compute manager shows "registered" and "up".

Upon returning to vSphere you may notice an error similar to the below screenshot:
nsxconfig.png
This error can be ignored as it will go away shortly. If the error persists please log an SR with VMware support.
 


Additional Information

This has been reported to occur after Supervisor Cluster license expiration.

Impact/Risks:
You are unable to log in to your supervisor cluster using kubectl vsphere login.