Check STS cert on VCSA/Windows: https://knowledge.broadcom.com/external/article?legacyId=79248
Check & Replace other certs on vCenter: https://knowledge.broadcom.com/external/article?legacyId=68171
sometimes vpxd.log will not update an error or logs are missing.
Environment
VMware vCenter Server 7.0.x
Cause
VCLS VMs were deleted and or previously misconfigured and then vCenter was rebooted
As a result for previous action, vpxd.cfg file was left with wrong data preventing vpxd service from starting. you may visit VCLS KB https://knowledge.broadcom.com/external/article?legacyId=80472 for more information on VCLS configuration.
Resolution
Do not skip any steps please do follow all the below-provided steps.
Connect to VCSA using SSH session with root
Take a backup from file /etc/vmware-vpx/vpxd.cfg
Confirm vpxd is not running / Stop vpxd using : service-control --stop vpxd
Remove the VCLS entries from the /etc/vmware-vpx/vpxd.cfg
Workaround 1:
Run the below command to remove the VCLS entries from the /etc/vmware-vpx/vpxd.cfg
sed '/<vcls>/,/<\/vcls>/d' -i /etc/vmware-vpx/vpxd.cfg
Workaround 2:
Manually edit file vpxd.cfg
vi vpxd.cfg
Remove the part that contains vcls section, looks like below: