Error: "The installer is unable to connect to the vCenter Appliance Management Interface" during the completion of Stage 1 of vCenter upgrade
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Error: "The installer is unable to connect to the vCenter Appliance Management Interface" during the completion of Stage 1 of vCenter upgrade

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Article ID: 313817

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • During the execution of stage 1 in the vCSA deployment, the installer encounters the error: "Unable to connect to the vCenter Appliance Management interface."
  • During Stage 1 of the deployment, the target was set to the ESXi host instead of the vCenter server (managing the same ESXi host)
  • On the ESXi host where the target VCSA VM is deployed, the following entries may be found in the /var/run/log/vmkernel.log:
YYYY-MM-DDTHH:MM:SS.###Z cpu85:41077519)NetPort: 1660: enabled port 0x2000077 with mac ##:##:##:##:##:##
YYYY-MM-DDTHH:MM:SS.###Z cpu85:41077519)etherswitch: L2Sec_EnforcePortCompliance:172: client testvm01 requested mac address change to ##:##:##:##:##:## on port 0x2000077, disallowed by vswitch policy
YYYY-MM-DDTHH:MM:SS.###Z cpu85:41077519)etherswitch: L2Sec_EnforcePortCompliance:252: client VM has policy violations on port 0x2000077. Port is blocked
YYYY-MM-DDTHH:MM:SS.###Z cpu88:41077516)NetPort: 1879: disabled port 0x2000077
YYYY-MM-DDTHH:MM:SS.###Z cpu52:65778)Net: 3740: disconnected client from port 0x2000077

Environment

VMware vCenter Server 6.7

Cause

During the vCenter upgrade, the installer deploys a vCenter Appliance as the target in Stage-1. This process may involve a MAC address change, which can result in the installer reporting an error when attempting to enable vCenter Server Appliance Management Interface (VAMI) access.

Resolution

This is an expected behavior.

As a workaround, perform one of the below steps:

  • Option A: Deploy the VCSA target appliance and configure it as the vCenter Server managing the ESXi host, rather than selecting the ESXi host itself.

    or

  • Option B: Configure "reject mac address change" value to "Accept" on the vSwitch in case if host is selected as deployment target.
    1. Log in to the ESXi host UI that was chosen as deployment target.
    2. Click networking on the left pane and click on virtual switches on the right.
    3. Select the vSwitch on which the target portgroup is configured.
    4. Click Edit Settings -> expand Security.
    5. Change the value for "mac address change" to "accept" (reject if set as default in vSphere 7.x and later)
    6. Click ok.

Additional Information

In certain scenarios, the error message "The installer is unable to connect to the vCenter Appliance Management Interface" may occur if port 5480 is blocked on the firewall, preventing the Windows workstation (from which the upgrade is being performed) from accessing the vCenter VAMI page (https://<vCenter_IP/FQDN>:5480) to proceed with upgrade Stage 2, port 5480 must be unblocked on the firewall between the Windows workstation and vCenter.