vSphere continues to work as normal even when connectivity between the Cloud Gateway Appliance and VMware Cloud Services is lost
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vSphere continues to work as normal even when connectivity between the Cloud Gateway Appliance and VMware Cloud Services is lost

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Article ID: 313738

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Updated On:

Products

VMware VMware Cloud on AWS

Issue/Introduction

Symptoms:

When attempting to login to a vCenter Server subscribed to VMware Cloud through the vSphere Client, a message is displayed stating that connectivity between the vCenter Cloud Gateway Appliance and VMware Cloud Services is lost. This message or connectivity doesn't impact any of your vSphere or vCenter functionality. You can continue to login to vSphere Client by enabling access via the steps outlined here. However the data on VMware Cloud services of vSphere will not be latest until the connectivity is restored.

 


Environment

VMware vSphere+ Cloud Services

Cause

Connectivity between the vCenter Server and Cloud Gateway Appliance or connectivity between the Cloud Gateway Appliance and VMware Cloud Services is lost. The connectivity doesn't impact any of the functionality with vCenter, vSphere ESXi, vSphere APIs or automation, vSphere client or the 3rd party tools. Everything continues to work normally.
 
The following can be possible reasons for disconnection from VMware Cloud: 

•    Network connectivity between vCenter Server and Cloud Gateway is lost
•    The Cloud Gateway machine has been deleted or powered off or losses connectivity

 

Network connectivity problems: 

•    Network connectivity problems can be caused by either network problems or misconfiguration in terms of proxy settings, firewall settings, etc. 
•    There is time drift between the Cloud Gateway and the vCenter Server machine. Verify that the clocks on the Cloud Gateway and vCenter Server are synchronized.
 
After connectivity is restored, it may take up to 2 minutes for the system to acknowledge the connectivity state change.

 

Offline login 

When connectivity to the VMware Cloud is lost, you can continue to login vCenter Server in same way you have been doing in past, no changes.  To perform administrative tasks that cannot wait for connectivity to be restored, or if it’s needed to troubleshoot connectivity issues 

After 7 days if the connectivity is not restored, you can continue offline mode using token generated within vSphere Client. To initiate the login flow 

  1. Open a browser and navigate to https://<vcsa-address>/ui/emergency or https://<vcsa-address>/ui/offline-access depends on vCenter version.

    The VMware Cloud Gateway is not connected to VMware Cloud. To log in to the vSphere Client, click Retry or use https://***/ui/offline-access. For more information, see the KB article.


     

  1. Enter your username in the input box. In order to use offline login, a user account must have the "vSphere Client > VMware Cloud offline login" global privilege. 

  1. Click the “Grant temporary access button”. This generates a special token for the user account, which is valid for a limited amount of time. 

  1. You are automatically redirected to the login page and can proceed with entering your credentials. 

P S: Every instance of offline login is audited in the vCenter server event log. 

Resolution

vSphere + is out of support. vSphere+/VCF+ customers who have connected their SDDC Manager/vCenter to the Cloud Console are encouraged to migrate from SaaS to on-premises deployments to benefit from our product investments and roadmap.

Reference KB : https://knowledge.broadcom.com/external/article/344975/transitioning-vsphere+vcf+vsan+-customer.html

Additional Information

Impact/Risks:

Migration needs to be performed from vSphere + to on premises environment. Refer KB 344975 for further details.