[VMC on AWS] HCX deployment roll back in a FAILED status
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[VMC on AWS] HCX deployment roll back in a FAILED status

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Article ID: 313721

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Updated On:

Products

VMware HCX VMware Cloud on AWS

Issue/Introduction

To clarify and provide a resolution for the customer.

Symptoms:
  • You may attempt to undeploy HCX from the Cloud. However, there is no option to undeploy HCX within VMC Console, the only option is to deploy HCX but Rolling Back Hcx is in a FAILED status.
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  • HCX is showing as Active on the VMC Console.
  • HCX Cloud Manager is present in the Mgmt-ResourcePool in Cloud vCenter.
     


Cause

This can be caused if the original HCX deployment did not complete successfully and is stalled, where an internal cleanup is required.

Resolution

Confirm if all steps have been completed to remove HCX from VMC - https://kb.vmware.com/s/article/74869
Please create a support request with VMC Global Support - https://kb.vmware.com/s/article/2006985 with the following information:
  • SDDC ID
  • Screenshot of the VMC Console Add-ons tab showing HCX is still active
  • Screenshot of the Mgmt-ResourcePool from Cloud vCenter showing HCX Cloud Manager is present
  • Confirmation that HCX can be entirely removed from the SDDC


Additional Information

Impact/Risks:
This prevents HCX from being completely uninstalled from the SDDC. This will prevent any future redeployments of HCX in the SDDC until it is completely cleaned up.