To provide a workaround to the error that is received when restoring guest files
Symptoms: When attempting to restore guest files for a VM snapshot using VCDR, the error "An unexpected error has occurred. If this situation persists, contact support" may be received. This error will be received for every VM and every VM snapshot (especially for larger VMDKs).
Cause
This is caused by a limit cache space, as VCDR will cache VMDKs on demand. In the case for large VMDK files, it will take a considerable amount of time. The UI has a predefined timeout of 60 seconds, which is not sufficient enough for larger VMs.
This issue is seen in VCDR versions v26 or earlier.
Resolution
The issue is expected to be fixed in future release.
Workaround: The workaround, in the current version, is to run the initial restore guest files workflow, wait 5 minutes after it fails, and then attempt again. This should resolve the error that is being seen in the initial attempt.
Additional Information
Impact/Risks: Attempts to restore guest files on larger VMs will fail on the initial attempt.