[VMConAWS] Unable to Delete a VMDK or directory from the Workload datastore
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[VMConAWS] Unable to Delete a VMDK or directory from the Workload datastore

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Article ID: 313697

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

Identifying reasons why some files may not be able to be deleted from the datastore.

Symptoms:
Deletion task of VMDK from the datastore fails with below errors

Error: Cannot complete the operation due to an incorrect request to the server.

Or

Error: Deletion of file or directory [WorkloadDatastore] <UUID>/Filename.vmdk from WorkloadDatastore was initiated from 'VMware vim-java [email protected]' and completed with status 'Failure'


Cause

Potential file locks exist from backup tool proxy VM. 
Possible corrupt CTK files.

Resolution

Check for exclusive lock held by a Virtual Machine Backup solution proxy VM.
  • Select the backup solution proxy VM from vSphere Inventory
  • Right click the VM > Select "Edit Settings..." or click on the Actions button in the VM summary > Select "Edit Settings..."
  •  Expand the Hard disk and validate if there are any VM disks matching the files you wish to remove
  •  Consult your back up solution if necessary on impact of removing a disk from the Proxy VM before continuing
  •  Select "Hard disk", Select "Remove device"
  •  Click on OK
  •  Retry the file removal operation
For corrupt CTK files follow KB2013520

Incase the above steps doesn't resolve the issue Engage VMware Support for assistance

Additional Information

Impact/Risks:
There should be no impact as long as the files being deleted are not in use