[VMC on AWS] Unable to delete the Snapshot due to ongoing Vsan resync
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[VMC on AWS] Unable to delete the Snapshot due to ongoing Vsan resync

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Article ID: 313694

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

Provides details about how to troubleshoot and fix the issue.

Symptoms:
The operation cannot be allowed at the current time because the virtual machine has a question pending: 'msg.hbacommon.outofspace: There is no more space for virtual disk 'VMxxxxx.vmdk'.

Under Virtual Objects of Cluster-X, we observe that the Hard disk of VM is in inaccessible state.

image.png

Cause

Changes in the accessibility occur when the cluster experiences more failures than the policy for a virtual machine object tolerates.

When a capacity device in the vSAN cluster approaches or exceeds the threshold level of 80 percent a resynchronization task triggered. 

Resolution

  • Wait for the vSAN Object synchronization to complete and validate the VM is in accessible state. You can monitor the resync task by navigating to Monitor Tab > vSAN > Resyncing Objects 
  • Once the resync is complete, please check in the vcenter task for snapshot removal task progressimage.png