[VMC on AWS] General System Error When Uploading OVA Files to Content Library in VMC SDDC
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[VMC on AWS] General System Error When Uploading OVA Files to Content Library in VMC SDDC

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Article ID: 313648

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

Provide workaround to resolve this issue

Symptoms:
When attempting to upload an OVA file into a Content Library, a user may receive the error, "Please update the order of files inside OVA such that manifest file comes before disks. Or update the manifest file to use SHA256 digests."
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Cause

The checksum is failing since vCenter Content library is expecting a SHA256 digest while the manifest file (.mf) which is part of the OVA template includes only a SHA1 digest

Resolution

The best resolution for this error is to upload the OVA/OVF file directly into the Compute Resource Pool, rather than uploading it into the content library

Workaround:
Best option:
  1. Log into vCenter
  2. Select Compute Resource Pool, right click and select, "Deploy OVF template"
  3. In the OVF deployment wizard, enter the URL and follow through with the deployment process
Another option:
  1. Updating the OVA file manifest to include a SHA256 digest instead of a SHA1 digest
  2. Updating the OVA and removing the manifest file completely (as this is optional)


Additional Information

Impact/Risks:
This error prevents a user from uploading an OVA/OVF file directly into a content library